Home

The Simply Fortran Interface

The interface in the Simply Fortran development environment is relatively intuitive. Each portion of the Simply Fortran windows is described in detail below.

Window Layout

The Simply Fortran window is divided into two main regions. The left side displays project management, file outline, and debugging tool panels. The right side displays Fortran editor tabs as well as the Build Status and Console tabs. These tabs can be separated into additional views to show multiple files side-by-side. The entire window is displayed below:

Simply Fortran Window

The menu and toolbar located at the top of the window are explained in subsequent sections.

The bottom of the window feature a small status bar. The left-most portion of the status bar is used for reporting Simply Fortran’s current work status and, when appropriate, the current version control mode and branch. Normally, this status will report “Ready” when editing text, managing projects, or configuring options. When a project build procedure is executed, this status will change to the appropriate text while the work is being performed. The right-most portion of the status bar contains the current cursor position within the editor.

Menu and Toobar

Simply Fortran features a modern menu and toolbar system, arranged by default as:

Simply Fortran title bar

The menus in Simply Fortran provide access to all the functionality in the suite. Many of the menu options also map to hotkeys to improve access.

File Menu

Entry Function
New Opens a new file in an editor tab
Open… Opens an existing file in an editor tab
Save Saves the file in the current editor tab
Save As… Saves the file in the current tab using a user-specified name
Save All Saves all tabs and the current project (if saved previously)
Close Closes the current active editor tab
Scratch Pads Submenu providing Scratch Pads management and creation functions
Version Control Submenu providing file-specific version control functions
Page Setup… Configures the page layout for printing
Print Prints the contents of the current tab
Recent Files Submenu listing the files most recently opened via the “Open…” menu item
Exit Closes Simply Fortran

Edit Menu

Entry Function
Undo Undoes the previous action within the current editor tab
Redo Redoes the previously undone action within the current editor tab
Cut Cuts the selected text in the current tab,placing it on the clipboard
Copy copies the selected text in the current tab to the clipboard
Paste Pastes text from the clipboard into the current editor tab
Delete Deletes thee selected text in the current tab
Select All Selects all text in the current editor tab
Select Matching Selects any other text that matches the current selection
Select Matching Words Selects any other word that matches the current selection
Selection Mode Allows changing selection mode between normal and block (rectangular)
Insert Submenu containing language-specific convenience structures for insertion into source code
Indent Indents the selected line(s)
Dedent Dedents (the opposite of “Indents”) the selected line(s)
Comment Line For supported languages , comments the selected line(s) in the current tab
Uncomment Line For supported languages , uncomments the selected line(s) in the current tab
Smart Indent File Indents entire file according to code structure, when supported
Find… Opens the Find dialog to search for text in the current tab
Find Again Performs the previous search specified from the current cursor position
Replace/Find Again Replaces the selected text with the specified text from the Find dialog and proceeds to the next matched text in the current tab
Find in Project… Opens the Text Search panel for searching all files in a project
Goto Line… Opens the line number specification dialog to move the cursor to a specified line
Bookmarks Submenu for toggling and navigating between bookmarks in the current editor
Languages Submenu for specifying the language parser to use in the current editor tab
Line End Characters Submenu for setting and converting the line end standard used (Windows/MS-DOS or Linux/*BSD)
Tabs Submenu for configuring and converting tabs in the current editor tab
Word Wrap Enables or disables word wrapping in the current editor tab

Project Menu

New Project Creates a new project
Open Project… Opens an existing project
Save Project Saves the current project
Save Project As… Saves the current project using a user-specified name
Switch To Switches to another open project
Close Current Project Closes the current project
Close All Projects Closes all open projects
Export Submenu providing project export options
Version Control Submenu providing project-specific version control functions
Recent Projects Submenu lists the most recently used four projects
Add Folder… Adds a folder to the current project
Add File(s)… Adds a file or files to the current project
Synchonize with File System Updates the project with all files and the folder structure present in the current project directory
View Makefile Opens the project’s current Makefile script
Options… Opens the Project Options window

Build Menu

Entry Function
Generate Makefile Constructs a makefile for the given project
Build Project Builds the current project’s target
Clean Removes any intermediate files and the target resulting from a previous build action
Launch Project Executes the project’s executable if the project results in an executable
Profile Calulates profiling results for the current target executable if enabled
Compile and Run Current File Compiles and executes the Fortran code in the current editor tab only

Debug Menu

Entry Function
Start Starts the debugger for the current project
Restart Stops the current program during debugging and returns to the beginning of the program
Stop Stops the debugger or detaches from an attached process
Attach Attaches the debugger to a currently running program
Step Over Steps over the code line to the next line in the current scope
Step In Steps into the subprogram (if possible)
Step Out Completes the current subprogram and returns to the calling entity
Continue Continues execution after pausing
Add Watch Expression… Opens a dialog to enter a watch expression
Clear All Watch Expressions Removes all watch expressions
Clear All Breakpoints Removes all breakpoints

Toolbox Menu

Entry Function
Configure Tools… Opens the Toolbox Manager to add and remove tools

Other entries for user-created tools will appear in this menu.

Options Menu

Entry Function
Compiler and Support Programs… Opens the Compiler and Support Programs options window
Appearance and Behavior… Opens the Appearance and Behavior options window
Enable Syntax Check When enabled, Simply Fortran will automatically and periodically check syntax in the project and any editor tabs
Enable Autocomplete When enabled, Simply Fortran will provide autocompletion suggestions while typing
Project… Opens the Project Options window

View Menu

Entry Function
Left Panel Submenu to open Simply Fortran’s left panels
Open New Terminal Submenu to allow opening a new terminal in a tab within Simply Fortran
Open Console Opens the input/output console for executables launched by Simply FortrN
Open Build Status Opens the tab which shows the building and compiling progress
Open Start Panel Opens the Simply Fortran Start panel in a tab if not already open
Package Manager… Windows Only: Provides access to the SF Package Manager if installed

The View menu will also list all open editor tabs.

Help Menu

Entry Function
Tutorial… Opens a simple tutorial
Contents… Opens the help browser
About Simply Fortran… Opens the splash dialog
Registration… Opens the registration dialog
Check for Updates… Contacts Simply Fortran’s home page to see if any updates are available

Toolbar Entries

The toolbar provides fast access for a selection of Simply Fortran functions found in the menus. The GOTO box, located to the far right, is explained further in GOTO box documentation.

Side Panel Toolbar

The side panel provides project management, file outlining, searching facilities, and debugging features. The different modes of panel operation can be switched using the small side panel toolbar:

The buttons switch between the following panels:

  1. Project
  2. Outline
  3. Element Search
  4. Modules
  5. Text Search
  6. Problems
  7. Debugging

When the window is resized to be smaller than this toolbar, the toolbar will show only the icons assoociated with each panel.

See Also

Using Simply Fortran
Editing in Simply Fortran
Project Pane